Multiple not working - only showing the keys

All ApPHP DataGrid script bugs discussion. Questions and requests here.
Please, use a $debug_mode = true; before you say "Why Nothing Works ?!" (solves 90% of all issues)

Moderator: alexandrleonenko

cooperlegend
Newbie
Newbie
Posts: 8
Joined: Jan 7th, '14, 16:09

Multiple not working - only showing the keys

Postby cooperlegend » Jan 18th, '18, 15:10

Datagrid Display issue

Code: Select all

    ## +---------------------------------------------------------------------------+
    ## | 6. View Mode Settings:                                                    |
    ## +---------------------------------------------------------------------------+

$fill_from_array = array("1"=>"Banned", "2"=>"Active", "3"=>"Closed", "4"=>"Removed"); /* as "value"=>"option" */

"teamids"=>array("header"=>"Teams", "type"=>"enum",      "align"=>"left", "width"=>"X%|Xpx", "wrap"=>"wrap|nowrap", "text_length"=>"-1", "tooltip"=>"false", "tooltip_type"=>"floating|simple", "case"=>"normal|upper|lower|camel", "summarize"=>"false", "summarize_sign"=>"", "sort_type"=>"string|numeric", "sort_by"=>"", "visible"=>"true", "on_js_event"=>"", "source"=>$fill_from_array, "multiple"=>"true"),


Shows "1,2,3,4"

I want it to show "Banned,Active,Closed,Removed"

Code: Select all

    ## +---------------------------------------------------------------------------+
    ## | 7. Add/Edit/Details Mode Settings:                                        |
    ## +---------------------------------------------------------------------------+

$fill_from_array = array("1"=>"Banned", "2"=>"Active", "3"=>"Closed", "4"=>"Removed"); /* as "value"=>"option" */

"teamids" =>array("header"=>"Team(s)", "type"=>"enum",       "req_type"=>"st", "width"=>"410px", "title"=>"", "readonly"=>"false", "maxlength"=>"-1", "default"=>"", "unique"=>"false", "unique_condition"=>"", "visible"=>"true", "on_js_event"=>"", "source"=>$fill_from_array, "view_type"=>"dropdownlist(default)|radiobutton|checkbox", "radiobuttons_alignment"=>"horizontal|vertical", "multiple"=>"true", "multiple_size"=>"7"),


Edit mode works fine, shows a list of names and stores the key codes as "1,2,3,4" :)

How do I get display to work ?

Cheers

administrator
Site Admin
Site Admin
Posts: 6037
Joined: Jan 7th, '09, 23:18
Contact:

Re: Multiple not working - only showing the keys

Postby administrator » Jan 23rd, '18, 11:24

This is how you defined $fill_from_array

cooperlegend
Newbie
Newbie
Posts: 8
Joined: Jan 7th, '14, 16:09

Re: Multiple not working - only showing the keys

Postby cooperlegend » Jan 23rd, '18, 12:51

Well "1,2,3,4" isn't much help to the user

administrator
Site Admin
Site Admin
Posts: 6037
Joined: Jan 7th, '09, 23:18
Contact:

Re: Multiple not working - only showing the keys

Postby administrator » Jan 24th, '18, 09:41

What version do you work with?
Try the latest 8.2.7


Return to “ApPHP DataGrid {bugs}”