FireBird problems

Talk about working with different database types

Moderators: ne_moj, zewa, vadimako, ne_moj, zewa, vadimako

administrator
Site Admin
Site Admin
Posts: 5988
Joined: Jan 7th, '09, 23:18
Contact:

FireBird problems

Postby administrator » Apr 20th, '11, 08:40

I use Firebird 2.5 superclassic x64 .. and
i had in my page: $db_conn =& DB::factory('ibase');
$result_conn = $db_conn->connect(DB::parseDSN('firebird://'.$DB
if changing to factory('ibase') to factory('firebird') i got error: extension not found,
so .. i changed in the pear\DB\firebird.php the function connect from
"if (!PEAR::loadExtension('pdo_firebird')) { // per la release 5 di php altrimenti usare interbase VDP"
to:
"if (!PEAR::loadExtension('interbase')) { // per la release 5 di php altrimenti usare interbase VDP"
then it worked great!!! i use the extention: php_interbase.dll the last one, and fbclient.dll 23 bit for version fb 2.5 x64 superserver.

I hope this can help others with same problem
many thanks and regards
Gerhard

Return to “Databases: different types implementation”