Page 1 of 1

webform not sending error occurred

Posted: Apr 26th, '17, 07:36
by paragate
Hi,
How come i get this errormessage when trying to send an email:
"An error occurred while sending email! Please try again later..."
It seem to me that the WebFormsComponent do have a problem submitting and therefore the different variables
do not pass through post to WebFormsController submitAction
$output .= CHtml::openForm('WebForms/submit', 'post', array('name'=>'form-contact', 'class'=>'form-horizontal')).self::NL;
And can you explain how to pass variables between component and controller with apphp framework?
Think it is around here where there are a checkpoint, if property_value is empty then it is not possible to sent form
protected/views/modules/settings.php:
54: $fieldValue = isset($valuesArray[$setting['id']]) ? $valuesArray[$setting['id']] : $setting['property_value'];
regards

Re: webform not sending error occurred

Posted: Apr 26th, '17, 18:10
by administrator
Click on F12 in yuor browser and try to debug the response from the server.

Re: webform not sending error occurred

Posted: May 14th, '17, 21:08
by paragate
Any idea why webform works in Safari and Firefox but not in Google Crome - is there som dev tools or else that must be set in crome to have it work? -

Now i can see that Safari will submit the form, but Google Crome will not!
Crome still get hanging in the WebFormsController line 77

Code: Select all

}else if(!CValidator::validateMinLength($message, 10)){
         $arr[] = '"status": "0"';
            $arr[] = '"error": "'.A::t('webforms', 'Message must be at least 10 characters in length!').'"';

always try to evaluate the form even the form is not empty,
Debugging in Crome says a "Synchronous XMLHttpRequest on the main thread is deprecated"..

Re: webform not sending error occurred

Posted: May 16th, '17, 07:59
by administrator
Try to update jQuery.